Cannot select multiple objects in outliner

FORUMS FORUMS General Help Cannot select multiple objects in outliner

Viewing 3 reply threads
    • #5364

      gavner
      Participant
      Up
      0
      ::

      Hi, without sensei installed you can press b to multi select objects, then right mouse click to select the objects instantly. However when i right mouse click with sensei installed i don’t get a menu to select the objects. I actually get the group objects menu instead.

      I also cannot use the shortcut ‘I’ to add a keyframe. I can only add the new keyframes using the animation tab on the left or by using the object>insert keyframe. I tried it on the current stable build and the latest dev build with the same results.

    • #5365

      admin
      Keymaster
      Up
      0
      ::

      That selection style in the outliner with all the highlighting I find really obnoxious. Blender added that right click menu several iterations after I had already devoted a custom right click menu to the outliner in Sensei Format. It’s not just a simple group menu it does other things. I’ll admit it’s faster to highlight everything, and then bring up another menu to select those things if your objects aren’t properly parented or grouped but not enough for me to want to have anything to do with that highlighting mess, which should by default select things and doesn’t. I could build a custom operator to make that selection highlighting thing do what it should actually do “select things”, I may consider this in the future, but once again this is not really an issue when you’re grouping and parenting things properly, that’s why Sensei Format uses a special grouping menu and options to make that task of grouping much faster and easier. Once things are properly ordered you can hold Ctrl and click on things to select, hide, or lock everything under its hierarchy. It’s been awhile since I’ve looked at this area of the code, it may be time for a border select in the outliner that actually selects things.

      You should be able to use “I” in both the 3D View as well as the dopesheet editor to insert a keyframe. It works on my build but perhaps this was something I fixed and forgot to document. A new version of Sensei Format is coming soon so you may wait until then. In general, I use “F” to insert a keyframe in the 3D View as well as the dopesheet editor. In Sensei Format pressing F inserts a keyframe and advances the timeline by a second (whatever frame rate you happen to have the timeline set to), it’s very useful for pumping out quick test animations (Ctrl-F to go back a second). For property values you wish to animate, you’ll still need to use I with your mouse hovered over the property you wish to animate (Blender’s api won’t allow me to get around this).

    • #5368

      gavner
      Participant
      Up
      0
      ::

      Thanks for the insight i appreciate it.

    • #5369

      admin
      Keymaster
      Up
      0
      ::

      No problem. Also, I went ahead and did this. The next version of Sensei Format, “B” to border select in the outliner now simply selects all items directly bypassing the highlighting stuff. I’ll be releasing it soon.

Viewing 3 reply threads