Issue with preview Z-buffer

FORUMS FORUMS General Help Issue with preview Z-buffer

Viewing 3 reply threads
    • #2144

      MoonUnit
      Participant
      Up
      0
      ::

      Hi!
      I am working with PNG with Alpha channel, I assigned it as texture material to a plain but in the preview window for some reason anything behind the plain is not rendered. This makes building scenes complicated. I tried playing with the GL settings and with the material and texture properties without any good result. I suppose it’s something related to z-buffer of the preview engine but I have no idea how to solve it.
      Does anyone know any plug-in, setting or anything else that I can use to solve this issue.

      Ewa.

    • #2146

      admin
      Keymaster
      Up
      0
      ::

      I remember having this problem in the past. I’ve been messing around with this for a few minutes and can’t recreate the problem though. What version of Blender are you using? No matter what I press or change I can’t seem to recreate this issue.

      Is this just one plane, or two using the same image? I’m curious because if it’s one plane, then that means Blender is showing the transparent bits around the lighting effects, but when it gets to the hazy area starts bugging out. I wonder if it has to do with the way the PNG was saved. Try downloading a few random transparent PNGs off the web and putting them in its place to see if it still has the same issue. Honestly I wouldn’t think that this was the problem but it’s worth a try. I wonder if Blender looks at 8 and 24 bit PNGs differently or if a PNG is dithered in an unusual way, this happens.

    • #2149

      MoonUnit
      Participant
      Up
      0
      ::

      Hi!
      I found the solution! And it’s all thanks to you!
      I tested what you suggested and nothing worked, so I started again reviewing all the properties of the material, taking note of each and every setting to post them to you.
      Doing this I found a Transparency checkbox under Display, under the Object (cube icon); when this check is active, transparency renders perfectly! Strangely enough, not a single tutorial mentions it.

      Even though the issue was not related to the png, your answer indeed saved my work, I would have surrendered by now otherwise.

      Thank you very much!

    • #2150

      admin
      Keymaster
      Up
      0
      ::

      That’s good. Glad you figured it out. Messing around with this now, I see that the transparency works properly if the object is selected, but if it’s not then I guess Blender tries to conserve resources unless this option you found is check marked. Glad you found this. I’ll integrate this into Zero Brush settings to be automated for transparent layers. I’m sure that will leave a lot of people less dismayed in the future.

Viewing 3 reply threads