Key frame snapping issue

FORUMS FORUMS General Help Key frame snapping issue

Viewing 2 reply threads
    • #4262

      lexomir
      Participant
      Up
      0
      ::

      None of my timeline auto snapping is working correctly. In the attached gif you can see that right clicking somewhere with ‘Nearest Frame’ auto-snapping enabled results in the cursor jumping back multiple frames, skipping over keyframes. I just grabbed Sensei Format last week, so it’s not an outdated version.

      Am I missing something here?

    • #4278

      admin
      Keymaster
      Up
      0
      ::

      No you’re not missing anything. It appears that when you’re working with keyframes this close together there are some issues with the code. If you were to zoom out (scroll middle mouse button back) and moved the frames farther apart, you’d probably see the snapping working properly. At this zoomed in of a level, you shouldn’t really need snapping at all because when you let go of either the cursor or a selection of keyframes, the placement is pretty deliberate. You can disable cursor snapping by clicking on the expand options icon (three little lines stacked on eachother next to the menu that says dopesheet) then select View/ Use Cursor Snap. I do however need to adjust the code to account for when you’re this zoomed in on the frames and will include an update soon. Thanks.

    • #4279

      lexomir
      Participant
      Up
      0
      ::

      Ok, great. Thanks for the help!

Viewing 2 reply threads