Metallic Object Reflections Don’t Follow Video Frames

FORUMS FORUMS Rendering Metallic Object Reflections Don’t Follow Video Frames

Viewing 3 reply threads
    • #34148

      MetazDescendaz
      Participant
      Up
      0
      ::

      Hi guys,

      Apologies for the simplicity of the issue but I am new to this.
      The thing is I am really trying to find a solution to this from a tutorial but I don’t know how to search for it.
      None of the results I get are relevant.

      In short, I have a spinning obj, 100% metallic surface, I added a video as an image texture in shading,
      chose the same video for my object in shading.

      Thing is when I hit play, the background video of the “world” environment keeps playing as normal, but the reflections on the object are frozen to the very first frame of the video. When I hit pause, then it updates the reflection to whatever frame happened to be showing at that moment.
      But when I fast scroll through all the frames, It magically renders the reflections of the video on the object as intended.

      But when I try rendering, the reflections are stuck on the first frame again.

      Here is a screen grab of the above along with the shading screenshots for both object and world.
      https://www.dropbox.com/s/idyhvxb2yjnvlwn/Blender%20Issue%20With%20Reflections.mov?dl=0 

      Any help appreciated. It’s a big music releases and I’d like to deliver on the above if possible.
      Thank you so much

    • #34149

      admin
      Keymaster
      Up
      0
      ::

      Cool video! I’m not sure why it’s not updating. When you say render do you mean you rendered it to a video file and it still doesn’t work as an mp4 or png sequence or whatever you rendered it as? Or do you mean just when you press Play it gets stuck while in the 3D View? Have you tried test rendering in Cycles (you could shrink down the output size and samples real small just to see what it would look like so it doesn’t take a thousand years to render)? If that works, and all else fails, you could render it in Cycles over night or something.

    • #34151

      MetazDescendaz
      Participant
      Up
      0
      ::

      Hi,

      both actually. I tried rendering it into a mp4 video output and png sequence and same thing happened.
      And also when I hit play in 3D view the reflections are frozen to the first frame (or whichever frame corresponds when I hit pause and play again)

      I will try Cycles tonight. Thank you

    • #34153

      MetazDescendaz
      Participant
      Up
      0
      ::

      Hi Admin,

      unfortunately Cycles didn’t even render an image. It was basically a black background with a few white pixels left and right.

      I did however render the whole video with Eevee.
      https://www.dropbox.com/s/ww6nwt5esrtidm3/AINM%20-%20EEVEE%20Render__blender0000-8280.mp4?dl=0

      and then manually clicked through to frame 1250 and got a screen recording with Quicktime demonstrating the wanted result. Kind of.
      https://www.dropbox.com/s/zg5r8gwjwo6o46e/1%20-%201250%20FRAME.mov?dl=0

      any thoughts ?

      Thank you

Viewing 3 reply threads