Mug modeling problem.

FORUMS FORUMS General Help Mug modeling problem.

Viewing 8 reply threads
    • #11416

      sankaud
      Participant
      Up
      0
      ::

      Hi All,

      I am new to Blender and I am following Sensei tutorials on the youtube in order to get some understanding of the software. I believe these are great tutorial videos and I did all ok until I came across subsurface modeling tutorial where you have to model a mug and dinner set. No matter what I do I can’t get the same modeling features as in video after 9.45 of the video. I thought this is do something with the Blender version so I have uninstalled and installed Blender 2.74 and the result is same. I’m still scratching my heard for the answers and hope someone can help.

    • #11417

      admin
      Keymaster
      Up
      0
      ::

      Hi. Thanks. If you watch the Blender Crash Course series from the beginning at youtube.com/blenderforums you’ll see the series uses a special addon called Sensei Format. This addon is free and the video explains how to download and install everything. This addon is necessary to follow along with the videos. A message about this is also shown at the beginning of every single video in the playlist. Also you should be using the latest version of blender and only stable builds from the official Blender download page blender.org/download. Everything is explained in the second video of the Blender Crash Course playlist.

      I built Sensei Format to make Blender easier to learn and use. It makes a lot of tweaks to the Blender layout, adds many new functions and simplifies others. There are also a few minor hotkey tweaks throughout. Everything is documented in the user manual and the training videos as you watch them. You can download it here blenderforums.org/store. If you click on the Sensei Format banner on the store page, this will link you directly to the install video and playlist.

    • #11419

      sankaud
      Participant
      Up
      0
      ::

      I did watch the video series from the beginning and I have already installed Sensei format yet I sill have the modeling issue. I believe I am not alone in this as I have seen a comment on the youtube video by another user with the same issue. I am not sure whether this has to do something with the hardware or software. Any help is much appreciated.

    • #11420

      admin
      Keymaster
      Up
      0
      ::

      Hi. Sorry. Didn’t realize you were using Sensei Format. Are you talking about the tools in the properties shelf (right side of screen in 3D View) under the display menu? The part where I turn off cage edit in the video? That menu is not showing up in your version or do you mean something else? The only difference with that menu now and at the time of the video is that a box has been added to some of the menu options. I don’t seem to notice any other tool set pop up around 9.45 in the video?

      Or do you mean the modeling tools in the toolshelf (left side of screen in 3D View) under where “Extended” is highlighted in the video? If those tools aren’t showing up (or even if I’m guessing the wrong issue) there is a good chance that using Blender version 2.74 (which is about a year old now) may be conflicting with the code. Occasionally the developers update the code to Blender in a way where it is required to be changed in Sensei Format also to work for new versions. Any reason you can’t update to 2.77, the latest, official, stable release of Blender? Actually, once a day, Sensei Format should be prompting you with the option to update Blender unless you’ve disabled the Auto Update feature.

    • #11421

      admin
      Keymaster
      Up
      0
      ::

      If I’m totally off base again, you may try taking a screenshot of your computer with Blender open when you’re having the issue and uploading it here.

    • #11422

      sankaud
      Participant
      Up
      0
      ::

      Hi,
      I have installed 2.74 just to see whether this a software glitch and went back to 2.77a after I found that is not the case.
      I have attached some images and you can see what is going on with the model.
      mug1.jpg : this is where I Alt+select the faces around the mug.
      mug2.jpg : this the same one with cage editing off.
      mug3.jpg : extrude command. looks nothing like your model.
      mug4.jpg : scale the faces still nothing like your model. your are scaling along the Z axis but mine open to X-Y plane. I have tried to use Shift + Z and other methods to limit it to Z but nothing works. Still wondering whats going on.

    • #11433

      admin
      Keymaster
      Up
      0
      ::

      In the first image where you say you alt-select the faces around the mesh, it appears this is an edge selection not faces. In fact I’d say it was if it weren’t for the fact that at the bottom of the 3D View the mesh selection type is clearly set to faces. I think what’s going on here is your loop of faces is so squished together that they appear as an edge loop even with cage editing on. Also, cage editing is when the edges are wrapped smoothly around the object. You referred to the second image as “with cage editing off” when that is actually with it on… I get that it’s kind of confusing considering the fact that when it’s off it actually looks like the mesh is sitting in a cage… or maybe I screwed up in the video and said off when I meant on, if so, sorry.

      So, with cage editing off (appears as boxy edges around smooth mesh), before you extrude or scale anything, try to edge select a loop of edges first and put some distance between the faces which are using it. Shift-scroll up for edge selection or just click the edge select icon in the bottom 3D View menu while in edit mode, and alt-select a loop near the top and start moving things up and down (hold middle mouse to constrain to Z axis or just tap Z after pressing G to move the edge loop up or down) to put enough distance between these edge loops so that when you switch back to face selection and loop select the faces it appears as an actual loop selection of faces and not an edge loop. Make sure that when you’re adjusting these edge loops you don’t overlap one on top of the other. Basically, if you do a loop selection of faces and it appears to be an edge loop (and especially if doing this with cage editing off) then this means your loop of faces is way to squished together or even possibly overlapping and extruding is going to be a mess. Hope that makes sense.

    • #11444

      sankaud
      Participant
      Up
      0
      ::

      Hey Sensei, seems like it did the trick. but it was extruding back faces and it looked dark. I wonder why the software act differently on different computer systems. Anyway thanks for your help.

    • #11445

      admin
      Keymaster
      Up
      0
      ::

      Glad you got it worked out. The software mostly acts the same regardless of what system you’re using. The problem is, this stuff can get really complicated. I may have been moving to fast at parts in the tutorial, I’ll definitely keep that in mind the next time I make a video visiting the topic.

      Whenever you see a “dark” face, what you’re seeing is the backside of a face. In 3D we refer to the direction of a face as its “normal”. This lets us know which side of the polygon face Blender will bother to render, come render time. If it’s dark, the face won’t be rendered. Normal direction is also used for a bunch of other stuff in 3D as well, but we’ll save that for another time.

      If you click on an object such as a cube while in Object mode, you’ll notice over to the far left of the screen at the bottom of the list of menus a menu called “normals”. If you click this open you’ll see the option “Double Sided”. With this option checked, there will be no more dark sided faces because this option tells Blender to render the polygon face no mater what direction it’s being viewed from… the downside is this can also greatly increase render times.

      Most of the time you’ll want to just keep an eye on stuff and try to make sure that the normals (faces) are facing towards the direction you need them to while you’re extruding and editing your mesh. There’s also tools you can use to flip the normals as well as attempt to make all of the normals in the object point towards one direction. If you press “Tab” to go into edit mode with a cube or something selected, in the Sensei tab under the “Extended” mesh tools, at the bottom there are four buttons side by side, vertex tools, edge tools, face tools, and clean up tools (reads as “More Tools” in the caption and looks like a mesh triangle).

      If you click on the clean up tools (button at the end) under “Dissolve Limited” there are two options “Fix Normals” and “Flip Normals”. Fix Normals will attempt to make all the faces point in one direction, and Flip Normals will flip the direction of the normals. Make sure you select everything first before using “Fix Normals” or they won’t be included in the operation.

      Sorry this took so long to get figured out but I appreciate the effort you put into solving this problem.

Viewing 8 reply threads